Funziona!!! grazie mille!! anche con la versione 2.3.4