Puoi essere più preciso? Se il firmware è il JVT usa questo http://forum.xda-developers.com/attachment.php?attachmentid=741552&d=1317892633, che è la 4.3.

Se invece hai la JVS usa la 4.1...