Ciao a tutti ragazzi, oggi pongo alla vostra attenzione un bel problemone per il quale cerco da giorni una soluzione, ma con piuttosto scarsi risultati. Nella speranza di trovare qualcuno a cui sia già capitato, o che ne capisca comunque qualcosa in più di me, cercherò di essere il più chiaro ed esaustivo possibile.


Dunque, possiedo un S4 mini comprato a luglio, no brand, non d'importazione, che funziona alla grande e senza problemi per tre mesetti circa dopo l'acquisto. Verso ottobre credo, faccio il primo aggiornamento del firmware direttamente dalle impostazioni del telefono. Tutto okay per un paio di giorni fin quando mi ritrovo il cellulare spento senza apparente ragione. Lo riaccendo, e dopo un paio di minuti buoni passati sul logo samsung, noto con mio grande stupore che lo smartphone era tornato alle impostazioni di fabbrica con annessa formattazione della memoria interna. Qualche giorno dopo, succede la stessa cosa, poi funzionamento perfetto per qualche settimana. Da lì comincio a notare più o meno vistosi rallentamenti all'apertura della galleria e qualche immagine che di tanto in tanto si corrompeva, compariva questo per intenderci: screenshot_2013-10-28-23-13-11_resized1.png


Non essendo comunque un gravissimo problema, arrivo ai primi di gennaio senza preoccuparmene troppo. E qui comincia il calvario. Di punto in bianco, una mattina, iniziano i primi forti rallentamenti di tutto il sistema operativo. Risultava difficoltoso persino il passaggio da una scheda all'altra della home, che procedeva a scatti, per non parlare del menu impostazioni che si bloccava irrimediabilmente. Sulle prime riavvio il sistema, rimuovo la microSD, ma niente. C'è da dire che non ho mai sovraccaricato la ram con applicazioni pesanti e inutili, soltanto i vari Facebook, Messenger, Whazzapp e veramente poco altro. La RAM libera si attestava costantemente sui 500 e più mb. Anche il collegamento via usb al pc (mai un problema) risultava assurdamente instabile e pressochè inutilizzabile. Da dire che non ho mai usato kies. Dopo qualche altro riavvio dello smartphone comincia ad apparire la finestra di dialogo "il processo system si è bloccato in modo anomalo" che mi riportava, coi suoi tempi, alla home.


Qui mi rassegno a perdere nuovamente tutti i dati, e mi butto sul wipe data dalla recovery. Si ripristinano i dati di fabbrica, e sembra filare di nuovo tutto liscio. Almeno nelle successive sei ore. Poi tutto come prima. Stavolta però riesco a comandare il ripristino dati di fabbrica dal menu impostazioni, e nuovamente tutto bene per qualche ora, poi ancora crash su crash.


Ormai disperato, gioco la carta custom ROM. Positivamente influenzato dall'esperienza cyanogen mod sul mio vecchio Galaxy W, e consapevole del fatto che sarebbe poi stato comunque qualcosa di reversibile, vado di ClockWorkMod e flasho la cyanogen 10.1.3. Tagliando corto, dopo neanche mezza giornata di utilizzo mi ritrovo punto e a capo con i soliti crash e riavvii casuali del telefono. Stessa identica cosa con la cm11, che addirittura si bloccava alla schermata di avvio. In tutto ciò sempre fatto tutti i wipe del caso prima e dopo il flash, quindi data/cache/dalvik.


Essendomi ampiamente frantumato i (si può dire?), decido di riportare lo smartphone in stock per spedirlo in assistenza, e seguo passo passo la guida trovata sul forum "tuttoandroid".
La recovery torna quella originale, la rom stessa cosa (4.2.2 italiano no brand), ma il sistema risulta ancora "custom":img_20140112_223451.jpg

Non ho avuto il tempo nè la voglia di verificare se almeno questa rom si comportasse come tutte le altre, so soltanto che l'avvio fila liscio mentre non c'è modo di attivare il WiFi.


Ora, a me starebbe pure bene una custom purchè faccia il suo lavoro, e a quel paese la garanzia. Ma quando neanche così va bene, ho veramente voglia di rimandare tutto alla casa madre e che se la sbrighino loro. Sarei quindi felice se qualcuno avesse consigli su:
- In che modo ripristinare lo smartphone come mamma Samsung lo ha fatto per mandarlo in assistenza, o in alternativa
- Come riavere un sistema operativo stabile, magari avendo una base ultra-pulita da cui partire, visto che nonostante i vari wipe si torna sempre agli stessi problemi


Tante scuse per la prolissità e un grazie a te che hai letto fino alla fine, che tu mi possa aiutare o meno!